Drupal 10 deprecation errors

Filter errors
All occurences Affected projects Occurs in a top X project by usage Sort ascending Category Message
1 1 10000 Symfony API Parameter $event of method Drupal​\​x_frame_options_configuration​\​EventSubscriber​\​XframeSubscriber::onKernelResponse() has typehint with deprecated class Symfony​\​Component​\​HttpKernel​\​Event​\​FilterResponseEvent: since Symfony 4.3, use ResponseEvent instead
2 2 10000 Frontend API The 'popup' library is depending on a deprecated library. The core/jquery.cookie asset library is deprecated in Drupal 9.0.0 and will be removed in Drupal 10.0.0. Use the core/js-cookie library instead. See https://www.drupal.org/node/3104677
1 1 10000 Other problem #lazy_builder callback 'at_tool.lazy…' at key '0' is not callable.
5 4 10000 Info.yml or composer.json Value of core_version_requirement: ^8.8.6 || ^9.0.0 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.
1 1 10000 Frontend API The 'addtocal' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 10000 Twig API Using an "if" condition on "for" tag in "themes/contrib/drupal8_parallax_theme/templates/dataset/forum-list.html.twig" at line 55 is deprecated since Twig 2.10.0, use a "filter" filter or an "if" condition inside the "for" body instead (if your condition depends on a variable updated inside the loop). See https://drupal.org/node/3071078.
1 1 10000 Twig API Using an "if" condition on "for" tag in "themes/contrib/drupal8_parallax_theme/templates/dataset/forum-list.html.twig" at line 63 is deprecated since Twig 2.10.0, use a "filter" filter or an "if" condition inside the "for" body instead (if your condition depends on a variable updated inside the loop). See https://drupal.org/node/3071078.
1 1 10000 Twig API The spaceless tag in "themes/contrib/drupal8_parallax_theme/templates/field/link-formatter-link-separate.html.twig" at line 15 is deprecated since Twig 2.7, use the "spaceless" filter with the "apply" tag instead. See https://drupal.org/node/3071078.
1 1 10000 Twig API The spaceless tag in "themes/contrib/drupal8_parallax_theme/templates/form/dropbutton-wrapper.html.twig" at line 13 is deprecated since Twig 2.7, use the "spaceless" filter with the "apply" tag instead. See https://drupal.org/node/3071078.
1 1 10000 Twig API The spaceless tag in "themes/contrib/drupal8_parallax_theme/templates/form/select.html.twig" at line 13 is deprecated since Twig 2.7, use the "spaceless" filter with the "apply" tag instead. See https://drupal.org/node/3071078.
1 1 10000 Twig API The spaceless tag in "themes/contrib/drupal8_parallax_theme/templates/navigation/toolbar.html.twig" at line 30 is deprecated since Twig 2.7, use the "spaceless" filter with the "apply" tag instead. See https://drupal.org/node/3071078.
1 1 10000 Frontend API The 'toolbar-anti-flicker' library is depending on a deprecated library. The core/jquery.cookie asset library is deprecated in Drupal 9.0.0 and will be removed in Drupal 10.0.0. Use the core/js-cookie library instead. See https://www.drupal.org/node/3104677
1 1 10000 Symfony API Parameter $event of method Drupal​\​akamai​\​EventSubscriber​\​CacheableResponseSubscriber::onRespond() has typehint with deprecated class Symfony​\​Component​\​HttpKernel​\​Event​\​FilterResponseEvent: since Symfony 4.3, use ResponseEvent instead
1 1 10000 Frontend API The 'dismissed-cookie' library is depending on a deprecated library. The core/jquery.cookie asset library is deprecated in Drupal 9.0.0 and will be removed in Drupal 10.0.0. Use the core/js-cookie library instead. See https://www.drupal.org/node/3104677
1 1 10000 Symfony API Parameter $event of method Drupal​\​new_relic_rpm​\​EventSubscriber​\​ExceptionSubscriber::onException() has typehint with deprecated class Symfony​\​Component​\​HttpKernel​\​Event​\​GetResponseForExceptionEvent: since Symfony 4.3, use ExceptionEvent instead
1 1 10000 Symfony API Parameter $event of method Drupal​\​new_relic_rpm​\​EventSubscriber​\​NewRelicRequestSubscriber::onRequest() has typehint with deprecated class Symfony​\​Component​\​HttpKernel​\​Event​\​GetResponseEvent: since Symfony 4.3, use RequestEvent instead
1 1 10000 Other problem Call to deprecated function drush_mkdir(): See ​\​Symfony​\​Component​\​Filesystem​\​Filesystem::mkdir.
1 1 10000 Frontend API The 'drupal.ckeditor.bgimage.admin' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 10000 Other problem Call to deprecated method getAlgorith() of class Drupal​\​miniorange_saml​\​XMLSecurityKey.
8 5 10000 Drupal API, not rector covered Call to deprecated function drupal_get_installed_schema_version(). Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Use Drupal​\​Core​\​Update​\​UpdateHookRegistry::getInstalledVersion() or ​\​Drupal​\​Core​\​Update​\​UpdateHookRegistry::getAllInstalledVersions() instead.
1 1 10000 Symfony API Parameter $event of method Drupal​\​jsonapi_include​\​EventSubscriber​\​ResponseSubscriber::onResponse() has typehint with deprecated class Symfony​\​Component​\​HttpKernel​\​Event​\​FilterResponseEvent: since Symfony 4.3, use ResponseEvent instead
1 1 10000 Twig API Using an "if" condition on "for" tag in "themes/contrib/bfd/templates/content/book/book-export-html.html.twig" at line 38 is deprecated since Twig 2.10.0, use a "filter" filter or an "if" condition inside the "for" body instead (if your condition depends on a variable updated inside the loop). See https://drupal.org/node/3071078.
1 1 10000 Twig API Using an "if" condition on "for" tag in "themes/contrib/bfd/templates/content/book/book-export-html.html.twig" at line 42 is deprecated since Twig 2.10.0, use a "filter" filter or an "if" condition inside the "for" body instead (if your condition depends on a variable updated inside the loop). See https://drupal.org/node/3071078.
1 1 10000 Twig API Using an "if" condition on "for" tag in "themes/contrib/bfd/templates/content/forum/forum-list.html.twig" at line 56 is deprecated since Twig 2.10.0, use a "filter" filter or an "if" condition inside the "for" body instead (if your condition depends on a variable updated inside the loop). See https://drupal.org/node/3071078.
1 1 10000 Twig API Using an "if" condition on "for" tag in "themes/contrib/bfd/templates/content/forum/forum-list.html.twig" at line 64 is deprecated since Twig 2.10.0, use a "filter" filter or an "if" condition inside the "for" body instead (if your condition depends on a variable updated inside the loop). See https://drupal.org/node/3071078.
1 1 10000 Twig API The spaceless tag in "themes/contrib/bfd/templates/form/select.html.twig" at line 13 is deprecated since Twig 2.7, use the "spaceless" filter with the "apply" tag instead. See https://drupal.org/node/3071078.
1 1 10000 Twig API Using an "if" condition on "for" tag in "modules/contrib/starrating/templates/starrating-formatter.html.twig" at line 3 is deprecated since Twig 2.10.0, use a "filter" filter or an "if" condition inside the "for" body instead (if your condition depends on a variable updated inside the loop). See https://drupal.org/node/3071078.
1 1 10000 Frontend API The 'lazyload' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 10000 Frontend API The 'hover_preview' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 10000 Frontend API The 'hover_preview_media' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256


Results are from dataset #8389 from 2022-12-04T17:18. Report is ran by the Drupal Association regularly.