geolocation 3.x-dev Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
geolocation 3.x-dev Module 32814 100 ChristianAdamski, derjochenmeyer
Status Next step Instructions Drupal.org issues
Fix deprecation errors found Run Rector to fix some errors Some of the errors found are covered by drupal-rector automation (thanks to Palantir.net funding), which should be used to speed up resolving them. Check out the Project Update Bot patch in the issue queue. Get the automated fix committed first and resolve the manual problems afterwards. Drupal 10 compatibility issues
Filter errors
Occurrence in project All occurrences Affected projects Sort descending Category Error
1 1 1 Symfony API Parameter $event of method Drupal​\​geolocation​\​EventSubscriber​\​AjaxResponseSubscriber::onResponse() has typehint with deprecated class Symfony​\​Component​\​HttpKernel​\​Event​\​FilterResponseEvent: since Symfony 4.3, use ResponseEvent instead
1 1 1 Frontend API The 'geolocation.api' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 1 Frontend API The 'geolocation.geocoder.api' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 1 Frontend API The 'geolocation.geocoder.api' library is depending on a deprecated library. The "core/jquery.ui.autocomplete" asset library is deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. See https://www.drupal.org/node/3067969
1 1 1 Frontend API The 'location_input.client_location' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 1 Frontend API The 'location_input.geocoder' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
4 127 87 Drupal API, rector covered Call to deprecated function file_save_data(). Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Use Drupal​\​file​\​FileRepositoryInterface::writeData() instead.
5 208 125 Drupal API, rector covered Call to deprecated function file_url_transform_relative(). Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Use Drupal​\​Core​\​File​\​FileUrlGenerator::transformRelative() instead.
25 360 241 Info.yml or composer.json Value of core_version_requirement: ^9 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.
5 866 482 Drupal API, rector covered Call to deprecated function file_create_url(). Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Use the appropriate method on ​\​Drupal​\​Core​\​File​\​FileUrlGeneratorInterface instead.
1 658 658 Info.yml or composer.json The drupal/core requirement is not compatible with the next major version of Drupal. Either remove it or update it to be compatible. See https://drupal.org/node/2514612#s-drupal-9-compatibility.
2 1598 757 Drupal API, rector covered Call to deprecated function drupal_get_path(). Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Use Drupal​\​Core​\​Extension​\​ExtensionPathResolver::getPath() instead.


Results are from dataset #150 from 2022-09-25T12:04. Report is ran by the Drupal Association regularly.