maintenance_mode_response_header 1.0.0 Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
maintenance_mode_response_header 1.0.0 Module 0 10000 svdhout
Status Next step Instructions Drupal.org issues
Fix deprecation errors found Manually review and fix errors Based on our detection methods, none of the errors found are covered by automated fixes. However the errors found should individually have documentation links to help understand the changes. Review and fix the issues manually. In case an issue fix is possible to automate, please submit an issue at drupal-rector. Drupal 10 compatibility issues
Filter errors
Occurrence in project Sort ascending All occurrences Affected projects Category Error
1 3897 3309 Info.yml or composer.json Value of core_version_requirement: ^8 || ^9 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.
1 1 1 Symfony API Parameter $event of method Drupal​\​maintenance_mode_response_header​\​EventSubscriber​\​ResponseHeader::onRespond() has typehint with deprecated class Symfony​\​Component​\​HttpKernel​\​Event​\​FilterResponseEvent: since Symfony 4.3, use ResponseEvent instead


Results are from dataset #9317 from 2023-01-29T14:42. Report is ran by the Drupal Association regularly.