Filter projects
Name Result Error Project type Usage Sort ascending Group Total deprecations Total parsing errors Covered by rector Not covered by rector Non-Drupal deprecations Drupal 9 plan Rector patch
bootstrap_paragraphs 2.x-dev No problems found, info.yml change needed Module 5615 500 0 0 0 0 0 This module currently has no known compatibility issues, and is aiming for a release together with Drupal 9.
gacsp 1.x-dev No problems found, info.yml change needed Module 4156 500 0 0 0 0 0 Use this project instead: Googalytics
google_analytics_reports 3.x-dev No problems found, info.yml change needed Module 2351 1000 0 0 0 0 0 [#3113212] [#3102925]
contact_storage_export 1.x-dev No problems found, info.yml change needed Module 1219 1000 0 0 0 0 0 This module is Drupal 9 ready.
commerce_variation_cart_form 1.x-dev No problems found, info.yml change needed Module 1178 1000 0 0 0 0 0 Read more about this project’s readiness at [#3123947]
big_pipe_sessionless 1.x-dev No problems found, info.yml change needed Module 1103 1000 0 0 0 0 0 Read more about this project’s readiness at [#3046409]
editor_advanced_image 1.x-dev No problems found, info.yml change needed Module 1065 1000 0 0 0 0 0 EAI is already ready for Drupal 9 - see the issue [#3090753]
datatables 1.x-dev No problems found, info.yml change needed Module 984 1000 0 0 0 0 0 This module will be ported to and ready for Drupal 9 as soon as Drupal 9 has been released.
jsonapi_include 1.x-dev No problems found, info.yml change needed Module 827 1000 0 0 0 0 0 JSON:API Include 8.x-1.1+ supports Drupal 9. Enjoy.
nbsp 1.x-dev No problems found, info.yml change needed Module 609 10000 0 0 0 0 0 NBSP is already ready for Drupal 9 - see the issue [#3090751]
facets_block 1.x-dev No problems found, info.yml change needed Module 529 10000 0 0 0 0 0 This module is Drupal 9 ready.
fotorama_gallery 2.x-dev No problems found, info.yml change needed Module 481 10000 0 0 0 0 0 🎉This module is currently compatible with Drupal 9. See [#3062325]
quick_node_block 1.x-dev No problems found, info.yml change needed Module 457 10000 0 0 0 0 0 Help port this project at [#3123915].
webform_node_element 1.x-dev No problems found, info.yml change needed Module 391 10000 0 0 0 0 0 8.x-1.x-dev branch is D9 ready with the exception of tests.
http_response_headers 1.x-dev No problems found, info.yml change needed Module 370 10000 0 0 0 0 0 Ready for Drupal 9.
bg_img_field 1.6 No problems found, info.yml change needed Module 336 10000 0 0 0 0 0 8.x-1.5 is compatible with Drupal 9.
script_manager 1.x-dev No problems found, info.yml change needed Module 306 10000 0 0 0 0 0 Drupal 9 support is planned but not yet ready.
paragraph_view_mode 1.x-dev No problems found, info.yml change needed Module 298 10000 0 0 0 0 0 This module will be ported to Drupal 9 as soon as the Paragraphs module will be ready for D9.
media_library_theme_reset 1.0-beta2 No problems found, info.yml change needed Module 276 10000 0 0 0 0 0 Read about this project's readiness at [#3130320]
image_link_attributes 1.x-dev No problems found, info.yml change needed Module 261 10000 0 0 0 0 0 The version 9.x release of the Image Link Attributes module has been tested and is ready to go. I'll tag the 9.x release on the day Drupal 9 lands.
fortytwo 4.x-dev No problems found, info.yml change needed Theme 221 10000 0 0 0 0 0 Porting of this project is on it's way. See [#3062797]
google_optimize 1.x-dev No problems found, info.yml change needed Module 208 10000 0 0 0 0 0 Fully ported to Drupal 9
better_module_dependencies 1.2 No problems found, info.yml change needed Module 194 10000 0 0 0 0 0 #3103473: Add new key core_version_requirement in better_module_dependencies.info.yml
d8_google_optimize_hide_page 1.x-dev No problems found, info.yml change needed Module 179 10000 0 0 0 0 0 Fully ported to Drupal 9
dblog_filter 2.x-dev No problems found, info.yml change needed Module 117 10000 0 0 0 0 0 [#3058426] Test for Drupal 9 Deprecations
entity_share_cron 2.x-dev No problems found, info.yml change needed Module 111 10000 0 0 0 0 0
Once Drupal 9.0.0 will be released:
  1. a release will be done so it will still be compatible with all Drupal 8 versions.
  2. deprecated code will be cleaned up to be compatible with the last Drupal 8 core version and Drupal 9
  3. a new release will be done, this one will be compatible with Drupal 8 and Drupal 9.
editor_button_link 1.x-dev No problems found, info.yml change needed Module 104 10000 0 0 0 0 0 Focus for now is getting a stable 8 version. If we don't use deprecated code, we will be fine for Drupal 9 🙌😄
layout_options 1.x-dev No problems found, info.yml change needed Module 81 10000 0 0 0 0 0 This module passes the check-drupal tests for deprecated functions. Unless there are major changes in the core Layout structure, this should work fine with 9.
revive_adserver 1.x-dev No problems found, info.yml change needed Module 65 10000 0 0 0 0 0 The maintainer will try to keep the module D9 ready from the stable release day. See [#3091737]
glisseo 1.x-dev No problems found, info.yml change needed Theme 60 10000 0 0 0 0 0 Will be ready as soon as possible. Currently, there are no blockers.