bootstrap4_modal 2.x-dev Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
bootstrap4_modal 2.x-dev Module 762 10000 vhin0210
Status Next step Instructions Drupal.org issues
Fix deprecation errors found Run Rector to fix some errors Some of the errors found are covered by drupal-rector automation (thanks to Palantir.net funding), which should be used to speed up resolving them. Check out the Project Update Bot patch in the issue queue. Get the automated fix committed first and resolve the manual problems afterwards. Drupal 10 compatibility issues
Filter errors
Occurrence in project Sort ascending All occurrences Affected projects Category Error
1 1393 670 Drupal API, rector covered Call to deprecated function drupal_get_path(). Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Use Drupal​\​Core​\​Extension​\​ExtensionPathResolver::getPath() instead.
1 4395 3746 Info.yml or composer.json Value of core_version_requirement: ^8 || ^9 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.
1 1 1 Symfony API Parameter $event of method Drupal​\​bootstrap4_modal​\​Plugin​\​EntityBrowser​\​Display​\​Bootstrap4Modal::propagateSelection() has typehint with deprecated class Symfony​\​Component​\​HttpKernel​\​Event​\​FilterResponseEvent: since Symfony 4.3, use ResponseEvent instead


Results are from dataset #8389 from 2022-12-04T17:18. Report is ran by the Drupal Association regularly.