easy_email 2.1.x-dev Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
easy_email 2.1.x-dev Module 366 10000 zengenuity
Status Next step Instructions Drupal.org issues
Fix deprecation errors found Run Rector to fix some errors Some of the errors found are covered by drupal-rector automation (thanks to Palantir.net funding), which should be used to speed up resolving them. Check out the Project Update Bot patch in the issue queue. Get the automated fix committed first and resolve the manual problems afterwards. Drupal 10 compatibility issues
Filter errors
Occurrence in project Sort ascending All occurrences Affected projects Category Error
2 1083 778 Info.yml or composer.json Value of core_version_requirement: ^8.8 || ^9 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.
1 584 584 Info.yml or composer.json The drupal/core requirement is not compatible with the next major version of Drupal. Either remove it or update it to be compatible. See https://drupal.org/node/2514612#s-drupal-9-compatibility.
1 117 81 Drupal API, rector covered Call to deprecated function file_save_data(). Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Use Drupal​\​file​\​FileRepositoryInterface::writeData() instead.
1 32 22 Info.yml or composer.json Value of core_version_requirement: ^9.2 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.
1 1 1 Twig API The spaceless tag in "modules/contrib/easy_email/templates/easy-email-content-add-list.html.twig" at line 17 is deprecated since Twig 2.7, use the "spaceless" filter with the "apply" tag instead. See https://drupal.org/node/3071078.


Results are from dataset #8310 from 2022-11-27T17:12. Report is ran by the Drupal Association regularly.