editablevar 1.0.x-dev Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
editablevar 1.0.x-dev Module 2 10000 gabor_h, sachbearbeiter, umakart
Status Next step Instructions
Fix deprecation errors found Manually review and fix errors Based on our detection methods, none of the errors found are covered by automated fixes. However the errors found should individually have documentation links to help understand the changes. Review and fix the issues manually. In case an issue fix is possible to automate, please submit an issue at drupal-rector.
Filter errors
Occurrence in project Sort ascending All occurrences Affected projects Category Error
1 1153 919 Info.yml or composer.json Value of core_version_requirement: ^8.8 || ^9 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.
1 81 64 Twig API Class [redacted] extends deprecated class Twig_Extension: since Twig 2.7, use "Twig​\​Extension​\​AbstractExtension" instead
1 85 40 Twig API Instantiation of deprecated class Twig_SimpleFunction: since Twig 2.7, use "Twig​\​TwigFunction" instead
1 1 1 Twig API Parameter $env of method Drupal​\​editablevar​\​Twig​\​EditablevarExtension::editablevar() has typehint with deprecated class Twig_Environment: since Twig 2.7, use "Twig​\​Environment" instead


Results are from dataset #143 from 2022-08-14T12:03. Report is ran by the Drupal Association regularly.