feeds 3.x-dev Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
feeds 3.x-dev Module 27508 200 alex_b, Dave Reid, e2thex, febbraro, franz, Ian Ward, irinaz, jmiccolis, joelpittet, kking, MegaChriz, tobby, tristanoneil, twistor, Will White, yhahn
Status Next step Instructions Drupal.org issues
Fix deprecation errors found Manually review and fix errors Based on our detection methods, none of the errors found are covered by automated fixes. However the errors found should individually have documentation links to help understand the changes. Review and fix the issues manually. In case an issue fix is possible to automate, please submit an issue at drupal-rector. Drupal 10 compatibility issues
Filter errors
Occurrence in project Sort ascending All occurrences Affected projects Category Error
11 215 55 PHPUnit API Call to deprecated method setMethods() of class PHPUnit​\​Framework​\​MockObject​\​MockBuilder: https://github.com/sebastianbergmann/phpunit/pull/3687
8 16 4 Other problem Call to deprecated function libxml_disable_entity_loader().
3 818 415 Drupal API, not rector covered Relying on entity queries to check access by default is deprecated in drupal:9.2.0 and an error will be thrown from drupal:10.0.0. Call ​\​Drupal​\​Core​\​Entity​\​Query​\​QueryInterface::accessCheck() with TRUE or FALSE to specify whether access should be checked. See https://www.drupal.org/node/3201242.
1 1 1 Other problem Instantiation of deprecated class Drupal​\​feeds​\​Plugin​\​Type​\​FeedsAnnotationFactory. Deprecated in feeds:8.x-3.0-alpha6, and is removed from feeds:8.x-3.0. Implement ​\​Drupal​\​Core​\​Plugin​\​ContainerFactoryPluginInterface instead.
1 1 1 Drupal API, not rector covered Instantiation of deprecated class Drupal​\​Component​\​Bridge​\​ZfExtensionManagerSfContainer. Deprecated in drupal:9.4.0 and is removed from drupal:10.0.0. The class has moved to ​\​Drupal​\​aggregator​\​ZfExtensionManagerSfContainer.
1 79 31 Info.yml or composer.json Value of core_version_requirement: ^9.3 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.


Results are from dataset #150 from 2022-09-25T12:04. Report is ran by the Drupal Association regularly.