login_destination 2.x-dev Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
login_destination 2.x-dev Module 7620 500 3CWebDev, beautifulmind, ddrozdik, jng12, marcp, mithy, moshe weitzman, Oliver Huynh, perennial.sky, rsvelko
Status Next step Instructions Drupal.org issues
Fix deprecation errors found Run Rector to fix some errors Some of the errors found are covered by drupal-rector automation (thanks to Palantir.net funding), which should be used to speed up resolving them. Check out the Project Update Bot patch in the issue queue. Get the automated fix committed first and resolve the manual problems afterwards. Drupal 10 compatibility issues
Filter errors
Occurrence in project Sort ascending All occurrences Affected projects Category Error
8 2809 235 Drupal API, rector covered Call to deprecated method drupalPostForm() of class Drupal​\​Tests​\​BrowserTestBase. Deprecated in drupal:9.1.0 and is removed from drupal:10.0.0. Use $this->submitForm() instead.
5 50 34 Drupal API, not rector covered Call to deprecated function user_password(). Deprecated in drupal:9.1.0 and is removed from drupal:10.0.0. Use Drupal​\​Core​\​Password​\​PasswordGeneratorInterface::generate() instead.
4 338 269 Drupal API, not rector covered Drupal​\​Tests​\​BrowserTestBase::$defaultTheme is required in drupal:9.0.0 when using an install profile that does not set a default theme. See https://www.drupal.org/node/3083055, which includes recommendations on which theme to use.
1 592 67 Drupal API, rector covered Call to deprecated method assertRaw() of class Drupal​\​Tests​\​BrowserTestBase. Deprecated in drupal:8.2.0 and is removed from drupal:10.0.0. Use $this->assertSession()->responseContains() instead.
1 578 578 Info.yml or composer.json The drupal/core requirement is not compatible with the next major version of Drupal. Either remove it or update it to be compatible. See https://drupal.org/node/2514612#s-drupal-9-compatibility.
1 3 3 Info.yml or composer.json Value of core_version_requirement: ^8.7.10 || ^9 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.


Results are from dataset #8389 from 2022-12-04T17:18. Report is ran by the Drupal Association regularly.