unified_twig_ext 1.0.x-dev Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
unified_twig_ext 1.0.x-dev Module 913 10000 EvanLovely, evanmwillhite, Grayle, rembrandx, sghoweri
Status Next step Instructions Drupal.org issues
Fix deprecation errors found Run Rector to fix some errors Some of the errors found are covered by drupal-rector automation (thanks to Palantir.net funding), which should be used to speed up resolving them. Check out the Project Update Bot patch in the issue queue. Get the automated fix committed first and resolve the manual problems afterwards. Drupal 10 compatibility issues
Filter errors
Occurrence in project All occurrences Affected projects Category Error Sort descending
1 1620 768 Drupal API, rector covered Call to deprecated function drupal_get_path(). Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Use Drupal​\​Core​\​Extension​\​ExtensionPathResolver::getPath() instead.
1 1 1 Twig API Call to method compile() of deprecated class Twig​\​Node​\​Node: since Twig 2.7, use "Twig​\​Node​\​Node" instead
1 76 61 Twig API Class [redacted] extends deprecated class Twig_Extension: since Twig 2.7, use "Twig​\​Extension​\​AbstractExtension" instead
1 4 3 Twig API Class [redacted] extends deprecated class Twig_Node: since Twig 2.7, use "Twig​\​Node​\​Node" instead
2 4 3 Twig API Class [redacted] extends deprecated class Twig_TokenParser: since Twig 2.7, use "Twig​\​TokenParser​\​AbstractTokenParser" instead
4 8 3 Twig API Fetching class constant BLOCK_END_TYPE of deprecated class Twig_Token: since Twig 2.7, use "Twig​\​Token" instead
4 10 2 Twig API Fetching class constant STRING_TYPE of deprecated class Twig_Token: since Twig 2.7, use "Twig​\​Token" instead
2 4 2 Twig API Instantiation of deprecated class Twig_Error_Syntax: since Twig 2.7, use "Twig​\​Error​\​SyntaxError" instead
1 76 39 Twig API Instantiation of deprecated class Twig_SimpleFunction: since Twig 2.7, use "Twig​\​TwigFunction" instead
1 4907 4112 Info.yml or composer.json Value of core_version_requirement: ^8 || ^9 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.


Results are from dataset #148 from 2022-09-11T12:04. Report is ran by the Drupal Association regularly.