webauthn 1.x-dev Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
webauthn 1.x-dev Module 0 10000 colan, d70rr3s, emboss, ergonlogic, hermann77, spiderman
Status Next step Instructions Drupal.org issues
Fix deprecation errors found Manually review and fix errors Based on our detection methods, none of the errors found are covered by automated fixes. However the errors found should individually have documentation links to help understand the changes. Review and fix the issues manually. In case an issue fix is possible to automate, please submit an issue at drupal-rector. Drupal 10 compatibility issues
Filter errors
Occurrence in project Sort ascending All occurrences Affected projects Category Error
1 592 592 Info.yml or composer.json The drupal/core requirement is not compatible with the next major version of Drupal. Either remove it or update it to be compatible. See https://drupal.org/node/2514612#s-drupal-9-compatibility.
1 51 35 Drupal API, not rector covered Call to deprecated function user_password(). Deprecated in drupal:9.1.0 and is removed from drupal:10.0.0. Use Drupal​\​Core​\​Password​\​PasswordGeneratorInterface::generate() instead.
1 190 135 Info.yml or composer.json Value of core_version_requirement: ^8.9 || ^9 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.


Results are from dataset #8203 from 2022-11-20T16:30. Report is ran by the Drupal Association regularly.