ztools 1.0.x-dev Drupal 10 deprecation details

Name and release Project type Usage count Top X project by usage Maintainers
ztools 1.0.x-dev Module 0 10000 zengenuity
Status Next step Instructions Drupal.org issues
Fix deprecation errors found Manually review and fix errors Based on our detection methods, none of the errors found are covered by automated fixes. However the errors found should individually have documentation links to help understand the changes. Review and fix the issues manually. In case an issue fix is possible to automate, please submit an issue at drupal-rector. Drupal 10 compatibility issues
Filter errors
Occurrence in project Sort ascending All occurrences Affected projects Category Error
1 1067 768 Info.yml or composer.json Value of core_version_requirement: ^8.8 || ^9 is not compatible with the next major version of Drupal core. See https://drupal.org/node/3070687.
1 578 578 Info.yml or composer.json The drupal/core requirement is not compatible with the next major version of Drupal. Either remove it or update it to be compatible. See https://drupal.org/node/2514612#s-drupal-9-compatibility.
1 1 1 Frontend API The 'prevent-double-click' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256


Results are from dataset #8389 from 2022-12-04T17:18. Report is ran by the Drupal Association regularly.