Drupal 10 deprecation errors

Filter errors
All occurences Affected projects Sort descending Occurs in a top X project by usage Category Message
1 1 50 Drupal API, not rector covered Class [redacted] extends deprecated class Drupal​\​node​\​Plugin​\​Condition​\​NodeType. Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Use Drupal​\​Core​\​Entity​\​Plugin​\​Condition​\​EntityBundle instead.
1 1 50 Drupal API, not rector covered Call to deprecated method verbose() of class Drupal​\​Tests​\​metatag_extended_perms​\​Functional​\​PermissionsTest. Deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. Use dump() instead.
1 1 50 Drupal API, not rector covered Call to deprecated method verbose() of class Drupal​\​Tests​\​metatag​\​Functional​\​MetatagFieldTestBase. Deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. Use dump() instead.
4 1 50 Drupal API, not rector covered Call to deprecated method verbose() of class Drupal​\​Tests​\​metatag​\​Functional​\​MetatagTagsTestBase. Deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. Use dump() instead.
1 1 50 Drupal API, not rector covered Call to deprecated method verbose() of class Drupal​\​Tests​\​metatag​\​Functional​\​NodeJsonOutput. Deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. Use dump() instead.
1 1 50 Frontend API The 'drupal.paragraphs.admin' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'drupal.paragraphs.widget' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'drupal.paragraphs.add_above_button' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'drupal.paragraphs.actions' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'drupal.paragraphs.modal' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'field_ui' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'formatter.html_element' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'formatter.fieldset' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'formatter.tabs' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'element.horizontal_tabs' library is depending on a deprecated library. The core/jquery.once asset library is deprecated in Drupal 9.3.0 and will be removed in Drupal 10.0.0. Use the core/once library instead. See https://www.drupal.org/node/3158256
1 1 50 Frontend API The 'core' library is depending on a deprecated library. The "core/jquery.ui" asset library is deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. See https://www.drupal.org/node/3067969
1 1 50 Frontend API The 'widget' library is depending on a deprecated library. The "core/jquery.ui.widget" asset library is deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. See https://www.drupal.org/node/3067969
1 1 50 Frontend API The 'mouse' library is depending on a deprecated library. The "core/jquery.ui.mouse" asset library is deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. See https://www.drupal.org/node/3067969
1 1 50 Frontend API The 'position' library is depending on a deprecated library. The "core/jquery.ui.position" asset library is deprecated in drupal:9.2.0 and is removed from drupal:10.0.0. See https://www.drupal.org/node/3067969
1 1 50 Symfony API Parameter $event of method Drupal​\​devel​\​EventSubscriber​\​ErrorHandlerSubscriber::registerErrorHandler() has typehint with deprecated class Symfony​\​Component​\​EventDispatcher​\​Event: since Symfony 4.3, use "Symfony​\​Contracts​\​EventDispatcher​\​Event" instead
1 1 50 Symfony API Parameter $event of method Drupal​\​devel​\​EventSubscriber​\​ThemeInfoRebuildSubscriber::rebuildThemeInfo() has typehint with deprecated class Symfony​\​Component​\​HttpKernel​\​Event​\​GetResponseEvent: since Symfony 4.3, use RequestEvent instead
1 1 50 Other problem Call to method export() of deprecated class Doctrine​\​Common​\​Util​\​Debug: The Debug class is deprecated, please use symfony/var-dumper instead.
1 1 50 Twig API Parameter $env of method Drupal​\​devel​\​Twig​\​Extension​\​Debug::dump() has typehint with deprecated class Twig_Environment: since Twig 2.7, use "Twig​\​Environment" instead
1 1 50 Twig API Parameter $env of method Drupal​\​devel​\​Twig​\​Extension​\​Debug::doDump() has typehint with deprecated class Twig_Environment: since Twig 2.7, use "Twig​\​Environment" instead
1 1 50 Twig API Parameter $env of method Drupal​\​devel​\​Twig​\​Extension​\​Debug::kint() has typehint with deprecated class Twig_Environment: since Twig 2.7, use "Twig​\​Environment" instead
1 1 50 Twig API Parameter $env of method Drupal​\​devel​\​Twig​\​Extension​\​Debug::message() has typehint with deprecated class Twig_Environment: since Twig 2.7, use "Twig​\​Environment" instead
1 1 50 Twig API Parameter $env of method Drupal​\​devel​\​Twig​\​Extension​\​Debug::breakpoint() has typehint with deprecated class Twig_Environment: since Twig 2.7, use "Twig​\​Environment" instead
2 1 50 Drupal API, not rector covered Call to deprecated method findConfigEntityDependents() of class Drupal​\​Core​\​Config​\​ConfigManagerInterface. Deprecated in drupal:9.3.0 and is removed from drupal:10.0.0. Instead you should use ConfigManagerInterface::findConfigEntityDependencies().
1 1 50 Twig API Parameter $profile of method Drupal​\​webprofiler​\​DataCollector​\​ThemeDataCollector::__construct() has typehint with deprecated class Twig_Profiler_Profile: since Twig 2.7, use "Twig​\​Profiler​\​Profile" instead
1 1 50 Twig API Return type of method Drupal​\​webprofiler​\​DataCollector​\​ThemeDataCollector::getHtmlCallGraph() has typehint with deprecated class Twig_Markup: since Twig 2.7, use "Twig​\​Markup" instead


Results are from dataset #136 from 2022-06-26T14:32. Report is ran by the Drupal Association regularly.